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Guideline  
 

This article is to explain Project Management Concept as a quick reference 
through step by step guidance using Microsoft Project 2010 tool. 
 
The targeted audience is a beginner to the project management and 
experienced with MS Project 2010.  
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Step-1: Start Project 
  

Before beginning a new project, an organization must 
determine whether the project fits its strategic goals. Executives 
should classify proposed projects that focus on mission-critical 
activities as high-priority and projects that are peripheral to 
organization goals as lower priority.  
Before work begins, an executive sponsor should be identified. 
The organization should complete a high-level evaluation of the 
project’s business case , its limitations, and its technical and 
financial requirements. Finally, a project manager should be 
identified, who can then set up a project plan in Microsoft 
Project 2010. 

 

1. Create a new 
project file 

• To create a new blank project in Project, click the File tab. Click New, and then c   
Project. 

• To create a new project from a template, click the File tab. Select a template fro   
(local), Office Online Templates (Web), or Project Server Templates. 

2. Set the project 
start date 

Click the File tab, and then click Info. On the right side of the Information page, select a     
Date box. 

3. Define the 
project calendar 

Click the Project tab. In the Properties group, click Change Working Time. Identify wor   
working days and times for your project. 

4. Save the project 
file 

click the File tab. Click Save. In the File name box, type the project name.  
If you are publishing the project to Microsoft Office Project Server 2010, type the name     
include any values for custom fields that are required by your organization. 

 



 

 

Step-2: Plan the Tasks 
  

In the planning stage, you devise a workable scheme to accomplish the 
project’s goals. To do this, you identify the project’s milestones, 
deliverables, and tasks. This plan can be your work breakdown structure 
(WBS). You develop and refine the schedule, and identify the resources 
required to implement the project. 
 

 

1. Enter tasks Click the View tab. In the Task Views group, click Gantt Chart. In the Task Name field, 
enter tasks. Tasks can also include summary tasks, milestones, and WBS items. 

2. Decide how 
you want to 
schedule 
tasks 

In Project 2010, you can now schedule tasks manually in addition to having Project 
automatically schedule them. Select the scheduling method after you enter a new task by 
clicking one of the following in the Task Mode column: 

• Manually scheduled    With this method, Project won't move a task after it is 
created, even when resources are assigned to it, or tasks get linked to it, or if the 
Project calendar changes. New tasks are manually scheduled by default. 

• Auto scheduled   Use this method when you want Project to schedule the task 
based on dependencies, constraints, calendars, and other factors. 

Note   New tasks are manually scheduled by default. To make new tasks automatically 
scheduled by default, click the Tasks tab. In the Schedule group, point to Task Mode, and in 
the list, click Auto Schedule. 

3. Outline tasks  Create your task hierarchy, including tasks and milestones under summary tasks, which can 
represent phases or other work divisions. Click the View tab. In the Task Views group, click 
Gantt Chart. Select a task (or several tasks), and then in the Tasks group, click the Indent or 

Outdent button . 
Tip   If you created a summary task with a duration, start date, or finish date, then the tasks 
that fall under the summary task will not be rolled up to this summary task. They'll be 
independent of it. This is known as top-down scheduling.    

4. Enter 
durations 

Click the Duration field for a task and enter a duration. For Project 2010, you can enter 
duration in two different ways, depending on the scheduling method that is being used for 
the task.  

• Manually scheduled task    Enter duration as either a number or as text. For 
example, you can enter "Sometime after June," or "Two days after ship."  

• Auto scheduled task   Enter duration as a number. For example, type 4d to indicate 
4 days. To specify a milestone without duration, type 0d. To indicate that a duration 
is an estimate, add a question mark; for example, type 6d? 

Note   When using automatic scheduling, avoid entering start and finish dates for tasks. 
Instead, enter duration and let Project 2010 automatically set these dates, which might 
change anyway as resources are assigned to tasks. 

5. Link tasks to 
show 
relationships 

Click the View tab. In the Task Views group, click Gantt Chart. Select the tasks that you 
want to link, and then click the Link Tasks button  in the Tasks group, which is found 
under the Tasks tab. To change the default finish-to-start dependency type, double-click 
the line between the tasks that you want to change, and then select a task link from the 
Type list. 

6. Create 
deliverables 

After your project is underway, you might learn that other projects depend on your project 
as a deliverable. Click the View tab. In the Task Views group, click Gantt Chart. On the Task 

tab, in the Insert group, click Manage Deliverables and Dependencies . This feature 
requires Project Professional 2010 that is connected to Project Server 2010. 

 



 

 

Step-3: Assign Resources 
  

Assignments are the associations between specific 
tasks and the resources needed to complete them. 
You can assign more than one resource to a task. In 
addition to work resources (people), you can assign 
material resources (such as cement) and cost 
resources (such as travel) to tasks. 
  

1. Add resources 
to your 
project 

Click the View tab. In the Resource Views group, click Resource Sheet . In the Resource 
Name field, type the names of the resources you will use for this project.  
If you are using Project Professional, you can add resources from the enterprise resource pool. 
Click the Resources tab. In the Insert group, click Add Resources, and then click Build Team from 
Enterprise. This feature requires Project Professional 2010 that is connected to Project Server 
2010. 

2. Assign 
resources to 
tasks 

In the Gantt Chart view, select a task to which you want to assign a resource. On the Resources 

tab, in the Assignments group, click Assign Resources . Click the resource names, and then 
click Assign. 
Tip   Use the new Team Planner to drag and drop tasks around easily from one person to another 
within your team, or back and forth in the schedule. Click the View tab. In the Resources group, 
click Team Planner. You can even create new tasks on the Team Planner, or remove tasks—by 
just dragging or dropping.  

3. Enter the 
work hours 
resources 
spend on tasks 

When scheduling tasks, project managers sometimes prefer to enter the amount of work (or the 
amount of labor) needed to complete a task, rather than the duration for the task. Entering work 
reflects real-world scheduling. 
To enter work hours for resources assigned to tasks, add the Work column to the Gantt Chart 
view. Right click a column, and then click Insert Column. Type "Work", to select the Work column. 

4. Know your 
task type 

As soon as you assign resources to automatically scheduled tasks, Project 2010 determines how to 
schedule the task based on the task type. (Manually scheduled tasks don't use task types.) 
Durations might change as you assign resources to tasks.  
How task types work 
Work, duration, and units (% allocation) are determined by the formula: Work = Duration * Units. 

In a . . . If you revise work . . 
. 

If you revise duration . 
. . 

If you revise units . . 
. 

Fixed units task Duration changes Work changes Duration changes 
Fixed work task Duration changes  Units change Duration  changes 
Fixed duration task Units change Work changes Work changes 

 
• To set a default task type for the entire project, click the File tab, and then click Options.  

In the Default task type box, select Fixed Units (the default), Fixed Duration, or Fixed 
Work.  

• To change the task type for an individual task, click the Task tab, and then in the 

Properties group, click the Task Information button  . Click the Advanced tab, and 
then in the Task type box, click the task type that you want to create. 

5. Identify 
factors 
affecting task 
schedules 

You can use Project 2010 to help you understand how changes to one task can affect the rest of 
the project. Click the Task tab, and then in the Schedule group, click Inspect Task. A pane opens 
on the left showing the factors that affect the scheduling of the selected task. 
Tip   You can also see task scheduling information (such as scheduling mode, duration, and start 
and stop times) quickly by hovering the mouse over the task's Gantt bar.  

 



 

 

Step-4: Set the project Baseline 
  

 

Create a baseline or an interim plan so that later you can compare your 
up-to-date schedule to your baseline. Saving a baseline plan enables 
you to identify and solve discrepancies and plan more accurately for 
similar future projects. 
 

1. Save the 
baseline plan 

After your project plan is solidly in place 
for the finish date, budget, and scope, 
you can submit the plan for approval. 
Once it has been approved, save the 
baseline plan. Click the Project tab, in 
the Schedule group, click Set Baseline. 

2. View baseline 
data in a Gantt 
Chart view 

Click the View tab, and then click the 
Gantt Chart button. Click the Format 
tab, and then in the Bar Styles group, 
click Baseline. the baseline information 
is shown as the lower of the two Gantt 
bars for each task.  

3. View baseline 
data in a table 

Click the View tab. In the Task Views 
group, click Gantt Chart (or any view 
that includes columns). Point to Tables, 
and then select Variance. This table 
includes fields for baseline and variance 
start and finish. 

 
 



 

 

Step-5: Update Progress 
  

Updating the progress of your project is the only way to 
make sure it stays on track as work is performed. The focus 
at this point is on managing changes, updating the 
schedule, tracking progress, and communicating project 
information. 
Note   Project 2010 tracks three sets of dates: current, 
baseline, and actual.  When you first set the baseline, 
current = baseline. When a task is 100% complete, current = 
actual. Baseline, current, and actual values exist for the start 
date, finish date, duration, cost, and work. 

 

1. Manage 
changes 

Managing changes involves modifying durations, dates, dependencies, resource 
assignments, or tasks based on requested changes or new information. Keep the 
current fields up to date and compare them to the baseline. 

2. Track actual 
dates and 
durations 

It’s best to decide on a single method for tracking progress. You can enter 
percentage complete, actual start and finish dates, actual and remaining durations, 
or actual and remaining work.  
Click the Task tab, and select the task for which you want to enter actual progress. In 
the Tasks group, select the amount of progress done on the task  

.  
3. Track actual 

hours and 
costs 

If you want to enter actual and remaining work hours or costs, use the tracking table. 
Click the View tab. In the Data group, point Table, and then click Tracking. Enter 
progress data in the Act. Work or Act. Cost fields for the task. 
You can also use the tracking table to enter percent complete, actual start and finish 
dates, and actual and remaining duration. 

 

 



 

 

Step-6: View/report information 
  

 

Keep stakeholders and team members up-to-date on project 
progress by providing them with access to online or printed 
views and reports. 
 
Project 2010 provides many ways to print and distribute both 
detailed and overview information project information 
quickly and efficiently. 

1. Select a view Project 2010 has some old views and some new views to help you see project information and 
report it to others on your team or organization. Click the View tab. In either the Task Views 
group or the Resource Views group, select the view you want to use. There are many views, but 
the most useful ones include: 

• Team planner view   Move tasks easily from one person to another within your team, or 
back and forth in the schedule. You can create new tasks in the team planner or remove 
tasks—just by dragging them. 

• Timeline view   Place tasks, subtasks, or milestones onto a single timeline at the top of 
most views. You can copy the timeline into Word, PowerPoint, Excel, or Outlook. You 
can instantly create attractive project reports this way. Click the Timeline check box to 
see how the timeline works. 

• Gantt Chart view   View project tasks in a combination view, with columns on one side 
and bars along a timeline on the other side. 

• Calendar view   See project information in a familiar monthly or weekly calendar format 
that can be printed. 

2. Add a column Adding columns to a view is one of the easiest ways to create the view that meets your needs.  
Click the View tab. In either the Task Views group or the Resource Views group, select the view 
you want to use. Right click on a column header to the left of where you want to insert a new 
column, and then click Insert column. Type the name of the column you want to insert. 
Tip   You can also insert a custom column as easily as a built-in column. For example, if you want 
a column called "Deliveries", type that name when you insert a new column. If you want the new 
column to contain only numbers (to specify the number of deliveries), then right click the column 
down-arrow, point to Data Type, and select the type of data that the column should contain. 

3. Customize a 
view 

Customizing views beyond adding columns has been made considerably easier in Project 2010. 
Whether it’s the Team Planner, Timeline, or classic Gantt Chart, all formatting options are 
available on the Format tab.  
Select  the view you want to customize, and then on the Format tab click the type of view 
element you want to change, such as the bar styles on the Gantt Chart, callout text on the 
Timeline, or the gridlines and timescales of any views. 
Tip   If you want to filter, sort, or group tasks prior to printing, Click the View tab, and then in the 
Data group, click the Sort, Filter, or Group options. 

4. Print a view 
or report 

Set up the current view the way that you want it to look when printed. Click the File tab, and then 
click Print. A preview of the view will be printed appears on the right. 
Tip   Click in the preview part of the view to see the actual size of the view as it will be printed. 

5. Generate a 
report 

Click the Project tab, and then in the Reports group, click one of the following:  
• Visual Reports   Use visual reports to see your project’s data as a PivotTable report in Excel 2010 

or a PivotDiagram view in Visio Professional 2010. 
• Reports   Use basic reports to see your project's data in tabular reports that don't require Excel or 

Visio. These basic reports are collected in categories for easy selecting and printing. 
• Compare Projects   Use a compare projects report to view a report that displays changes in the 

current project compared to another project. 

 



 

 

Step-7: Close the Project 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

Just because your project is 
almost finished doesn’t mean 
that your work is done. You 
still need to resolve any final 
project details and obtain 
customer acceptance of final 
deliverables. Conduct a 
“lessons learned” session, 
recording information about 
areas for improvement and 
best practices. Make any final 
updates to the project plan. 
Finally, archive the project 
plan according to your 
organization’s guidelines. 
 

1. Create a final 
report 

Click the Project tab. In the Reports group, click Visual Reports to see your project’s 
data as a PivotTable report in Excel 2010 or a PivotDiagram view in Visio Professional 
2010. 
You can also view basic reports that don’t require Excel or Visio. Click the Project tab, 
and in the Reports group, click Reports. Double-click a report category, and then 
double-click the predefined report. Enter any requested information. A preview of the 
report appears. To print the report, click Print. 

2. Save a project 
as a template 

After completing a project, you should leverage what you’ve learned in the project by 
making it a template for future projects. Click the File tab, click Save As, and then in the 
Save As Type box, click Template. 
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